altium designer笔记

Altium designer

原理图的设计

1、左键单击元器件按住space键可以将其旋转,按X键左右旋转;按Y键上下旋转。

2、智能粘贴:Edit →smart paste 。

3、屏障:compile mask(编译时被屏障的不显示信息)。

4、消除编译警告:place→divectives→NO ERC。

5、按住ctrl键移动选定元器件,则元器件之间的导线可以任意伸缩。

6、放置总线BUS:总线名[0:n],然后place Bus Entry, 放置网络代码:place→ Net Label。例如: 总线格式:databus[0:9],在Bus Entry命名:databus0、databus2… databus9,另一端命名databus0、databus2…databus9则建立了一一对应的关系,及databus0对应databus0。

7、查找替换:Edit→Find and Replace Text 说明替换名字而已。

8、删除元器件先选中按住左键拉动虚线框包围元器件,即被选中。再按delete键。

9、Tools→Footprint manager封装管理器。Set as current:更改当前封装;accept change:接受改变。

10、SCH→SCH Inspector 显示信息和修改被选对象参数等。

11、引脚间的连线(连成直线):按住shift键单击space键。

12、原理图设计完成后生成报表:reports→bill of materials,按键Export则导出元件清单/也可以使用模版“Template”点击浏览“[…]”选择模版再导出元件清单。

原理图分等级式的设计

1、由顶层到底层设计:

先设计顶层建立连接关系,然后创建子图再进行部分原理的设计并保存。

Place→sheet symbol命名编辑后,放置端口:place→add sheet entry,在弹出的窗口设置properties下的name 格式:名[0..n]。多根线端口用总线连接。

子图的生成:左键单击选中sheet symbol,右击在弹出的菜单中选择create symbol actions→create sheet from sheet symbol。

设计完成之后进行检测确定是否匹配:Design→synchronize sheet entries and ports,如不匹配则修改之。

2、由底层到顶层设计:

先设计原理图再由原理图创建sheet symbol再建立连接关系

子图设计完成→创建原理图(可命名为top)→在工作区间单击右键→ sheet actions→create sheet symbol from sheet or HDL→在弹出的对话框中选择子图→确定。

原理图生成PCB

1、原理图设计完成后编译,检查是否有误,如有直至修改无误为止;

2、建立PCB文件并保存;

3、在原理图的工作环境中操作生成PCB封装图:Design→updata PCB document

PCB.pcDoc→Validate changes(确认改变)→Execute changes(执行改变)→确定。4、布局:全选→tools→component placement→reposition selected compenent则出现十字

型图标,单击左键依次将元器件合理放置。

5、全选→tools→component placement→(…) ,元器件的各种放置方式。

6、快速选择元器件:PCB→PCB Filter→输入如“iscomponent”→Apply。

7、放置Room Definition: design→Rooms→place rectangular(矩形的)/polygonal(不规则

的)Room。将元器件在room里面自动排例:tools→ component placement→arrange

相关推荐
相关主题
热门推荐